Simply Hits XTRA Connection Error
Incident Report for The Simply Hits Radio Network
Update
We are continuing to investigate this issue.
Posted Nov 14, 2022 - 13:00 GMT
Investigating
We are currently investigating an issue preventing listeners from tuning into Simply Hits Xtra across multiple platforms and streams.

We are redirecting the stream to Simply Hits FM temporarily whilst we investigate the issue.

Thanks,
Ebony T.
Posted Nov 14, 2022 - 13:00 GMT
This incident affects: The Simply Hits Radio Network (Infrastructure) and Simply Hits Xtra (Radio Server).